when connecting supertokens to my mysql database i...
# support-questions
s
when connecting supertokens to my mysql database im told i have to change it from localhost to my ip
r
That’s if you are using docker for supertokens
Cause if you give localhost to the docker container env var, it will point to inside the image
s
oh okay
so
r
I mean inside the container*
s
i looked into my settings and found my local ip
i changed it
but it didnt work
r
Is MySQL listening to all interfaces?
Cause be default mysql will only listen to localhost
s
dang
how can i change that pls?
r
I think you could google that 😅
s
🙈
r
I don’t remember it off the top of my head
s
sure
ill get back to you with an update
it also said something about setting the bind-address to 0.0.0.0 using mysqld.cnf
r
Yea. That listens to all interfaces. And that would work
You also need to add a users in mysql that would listen on all ips.
s
hey rp
i did it
you have to create a new user
the host has to be your ip address
grant him all priviliges
them
then go to the firewall and allow all connections
r
yes! great!
2 Views