https://supertokens.com/ logo
#general
Title
# general
d

Demna

05/31/2022, 7:11 AM
And when I test it:
Copy code
sh
$ node auth.js
node:internal/errors:466
    ErrorCaptureStackTrace(err);
    ^

Error [ERR_MODULE_NOT_FOUND]: Cannot find package '@middy/core' imported from /home/dsaghliani/Projects/supertokens-demo/server-lambda/auth.js
    at new NodeError (node:internal/errors:377:5)
    at packageResolve (node:internal/modules/esm/resolve:910:9)
    at moduleResolve (node:internal/modules/esm/resolve:959:20)
    at defaultResolve (node:internal/modules/esm/resolve:1174:11)
    at ESMLoader.resolve (node:internal/modules/esm/loader:605:30)
    at ESMLoader.getModuleJob (node:internal/modules/esm/loader:318:18)
    at ModuleWrap.<anonymous> (node:internal/modules/esm/module_job:80:40)
    at link (node:internal/modules/esm/module_job:78:36) {
  code: 'ERR_MODULE_NOT_FOUND'
}

Node.js v18.2.0
r

rp

05/31/2022, 7:13 AM
hey!
You might wanna try
npm install --save @middy/core
d

Demna

05/31/2022, 7:18 AM
God, that makes so much sense. Why didn't I think of that? Sorry, I'm still wrapping my head around Node and NPM.
Thank you!
3 Views